利用Dropbox等云存储搭建网站

低成本搭建网站有很多方法,比如gitpage或者云服务商提供免费福利,这里列出一些利用同步盘建站的服务

还有一些其他的免费架站方案

# KISSr

  • https://www.kissr.com/
  • 详细教程: https://free.com.tw/kissr/ https://archive.fo/bL0ky
  • 有免费服务,付费是每月5美元
  • 付费后允许自定义域名、无限带宽、无限存储空间和无限个网站数

# Cloud Cannon

  • https://cloudcannon.com/
  • 使用的是jekyll,可以用多种git服务部署比如GitHub和gitlab等等
  • 自带模板,可以直观的编辑网站,"所见即所得"
  • 有免费服务,付费每个月20.83美元起

# DropPages

  • http://droppages.com/
  • 详细教程: https://free.com.tw/droppages/ https://archive.fo/4E2rF
  • 有免费服务,付费每月5英镑起

# UpDog

  • https://updog.co/
  • 详细教程: https://51.ruyo.net/3526.html https://archive.fo/CZUW7 这个大佬的博客中有个很好的示例代码
  • 详细教程: https://free.com.tw/updog-co/ https://archive.fo/IJnJ0
  • 支持Google Drive 和Dropbox
  • 有免费服务,付费每月3美元
  • 付费后,无限站点数,无限网站文件夹共享,自定义主页,支持markdown渲染,站点密码保护
  • 仅有订阅制付费,一次性付费计划已被取消

# Site44

  • http://www.site44.com/
  • 详细教程: https://free.com.tw/site44-turns-dropbox-into-web-hosting/ https://archive.fo/SDP7w
  • 没有免费服务但是可以免费试用一个月,付费每月4.95美元起

# Pancake.io

  • https://www.pancake.io
  • 详细教程: https://free.com.tw/pancake/ https://archive.fo/Wbgyu
  • 支持 Dropbox 和 git 方式部署
  • 没有免费服务但可以免费试用一个月,付费每月5美元

# 其他

# Neocities

  • https://neocities.org/
  • https://free.com.tw/neocities/ https://archive.fo/VLtBK
  • HTML/CSS空间,仅支持上传
  • 免费服务1 GB 空间、200 GB 月流量,付费服务每月5美元50GB空间、3000GB流量

# Zymic

  • http://www.zymic.com/
  • https://free.com.tw/free-web-hosting-zymic/
  • 支持PHP5 / MySQL / FTP
  • 免费服务6 GB空间 50GB月流量,可以通过付费来提升配置
RouterOS 基础问题

RouterOS是一种路由操作系统,带有配套的GUI操作软件,也可以使用命令直接操作,功能齐全,使用方便.由于功能繁多需要从最基本的连接到互联网开始做起,这里记录了使用过程中的一些基础问题

# DD安装

wget http://download2.mikrotik.com/routeros/6.42.6/chr-6.42.6.img.zip -O chr.img.zip && \
gunzip -c chr.img.zip > chr.img && \
mount -o loop,offset=33554944 chr.img /mnt && \
ADDRESS0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY0=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS0 interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY0
" > /mnt/rw/autorun.scr && \
umount /mnt && \
echo u > /proc/sysrq-trigger && \
dd if=chr.img bs=1024 of=/dev/vda && \
reboot
1
2
3
4
5
6
7
8
9
10
11
12
dd操作时,目标路径可能不是 /dev/vda 而是 /dev/sda 或其他,操作前先 ls /dev 查看一下
1
wget http://download2.mikrotik.com/routeros/6.43.8/chr-6.43.8.img.zip -O chr.img.zip && \
gunzip -c chr.img.zip > chr.img && \
mount -o loop,offset=33554944 chr.img /mnt && \
ADDRESS0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY0=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS0 interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY0
" > /mnt/rw/autorun.scr && \
umount /mnt && \
echo u > /proc/sysrq-trigger && \
dd if=chr.img bs=1024 of=/dev/vda && \
reboot
1
2
3
4
5
6
7
8
9
10
11
12

# 安全加固

禁用不常用不安全的服务

/ip service disable telnet,f​​tp,www,www-ssl,api,api-ssl
1

禁用邻居发现

/ip neighbor discovery-settings set discover-interface-list=none
1

# 添加IP

添加网关和IP以连接互联网,dd安装时网关和IP设置的脚本应该自动写在 /mnt/rw/autorun.scr 中的,但是意外常有,这里还是写一下

#定义接口的IP和掩码
/ip address add address=192.168.2.233/24 interface=ether1
#定义网关
/ip route add gateway=192.168.2.1
1
2
3
4

# 端口映射

将外网访问 10.5.8.200 的 80 端口的数据映射到主机 192.168.0.18

/ip firewall nat add chain=srcnat action=masquerade
/ip firewall nat add action=dst-nat chain=dstnat dst-address=10.5.8.200 dst-port=80 protocol=tcp to-addresses=192.168.0.18 to-ports=80
1
2

上面的命令映射目标是一个IP,转发到公网主机时会遇到目标主机是动态IP的情况,这时候就需要一个定时脚本来定时更新IP地址,如何定时请查看下一部分

/ip firewall nat set 6 to-addresses=[:resolve cu.ddns.com;]

#使用 set 方法设置防火墙 nat 表中的编号为 6 的规则的 to-addresses 字段的值为 [:resolve cu.ddns.com;] ,也就是解析 cu.ddns.com 地址所得到的IP,关于[:resolve <arg>;]等语法请查看参考部分
1
2
3

# 定时任务

# Scripts

在Winbox 中 System > Scripts 即可找到此功能

如果设置 Scripts

Namecuddns

Source/ip firewall nat set 6 to-addresses=[:resolve cu.ddns.com;]

使用命令

system script> add name=cuddns source=/ip firewall nat set 6 to-addresses=[:resolve cu.ddns.com;]
1

那么这个给端口映射的目标主机换IP的脚本就设置好了,接下来是定时

# Schedule

system scheduler> add interval=300 name="autoddns" on-event=cuddns
#每300秒执行一次脚本 cuddns
1
2

# 查看资源占用

/system resource print
1

# 参考

DD安装部分 https://www.qedev.com/router/59061.html https://web.archive.org/web/20200422025111/https://www.qedev.com/router/59061.html https://www.kvm.la/1065.html https://web.archive.org/web/20200422031312/https://www.kvm.la/1065.html

安全加固部分 https://www.sklinux.com/posts/secrity/mikrotik%E8%B7%AF%E7%94%B1%E5%AE%89%E5%85%A8%E9%98%B2%E8%8C%83%E8%AE%BE%E7%BD%AE/ https://archive.vn/Xp09A

端口转发部分 http://www.irouteros.com/?page_id=186 推荐余松老师的 《RouterOS入门到精通》 https://www.ros9.com/755.html https://web.archive.org/web/20200422033539/https://www.ros9.com/755.html https://blog.csdn.net/wyf_fantastic/article/details/80083096

轻量好用的笔记软件

除去常用的OneNote,EverNote等热门的笔记应用外,还有轻量好用各具特色的笔记软件,比如可以将数据掌握在自己手中,自己定制主题,Markdown支持,好用的代码片段功能等

# Boostnote

  • 支持 Markdown 还有 snippet 功能
  • 依靠云服务同步,但本身无法联网
  • 支持全平台

# VNote

  • 支持 Markdown 还有 snippet 功能
  • 依靠云服务同步,但本身无法联网
  • 支持全平台
  • 可自定义主题
  • 支持全文搜索

# Joplin

Joplin - an open source note taking and to-do application with synchronisation capabilities

  • 支持 Markdown
  • 支持全平台
  • 支持文件附件和云存储

# Tea

  • 支持 Markdown
  • 支持云存储
  • 支持多种插件

# 自带云服务的笔记软件

  • https://standardnotes.org/
  • https://simplenote.com/

# 参考

局域网文件传输软件

平时会遇到内网设备间传输数据的需求,搜了许多的软件,记录以下这些

# 多平台

# 手机端

# 小型文件服务器

# FTP服务器

# 参考

  • https://www.lifewire.com/windows-ftp-servers-free-817577
使用docker运行安卓虚拟机

也许可以拿来搞云手机...

docker run --privileged -d -p 6080:6080 -p 5554:5554 -p 5555:5555 -e DEVICE="Samsung Galaxy S6" --name android-container budtmo/docker-android-x86-8.1

http://docker-host-ip-address:6080

# 参考

  • https://medium.com/@AndreSand/android-emulator-on-docker-container-f20c49b129ef https://archive.fo/ATpcf
  • https://hub.docker.com/r/ksoichiro/android-emulator
  • https://github.com/thyrlian/AndroidSDK
  • https://hub.docker.com/r/thyrlian/android-sdk
  • https://github.com/budtmo/docker-android